Notifications doesn't seem to work for me

Oct 24, 2011 at 10:16 AM

Hi,

I am having trouble getting my windows service to notify me on errors (or anything for that matter). I've tried SMTP and even good old file logging.

Am I configuring it incorrectly or could there be something else that's not triggering.

I am not seeing anything strange in the event logs so it makes tracing the error a bit hard.

I've done some changes to force things to fail.

My configuration file:

 

<monitorPack name="DEV Resources" enabled="True" agentRegistrationFile="D:\DevTools\QuickMon\DEV Agents.qmral" defaultViewerNotifier="Logging">
  <collectorEntries>
    <collectorEntry uniqueID="5c2f7508-a145-45eb-92ad-acb9c5c9c643" name="Mobile Operators" enabled="True" isFolder="False" collector="HttpPing" dependOnParent="" collectOnParentWarning="False" repeatAlertInXMin="0" alertOnceInXMin="0" delayErrWarnAlertForXSec="0">
      <config>
        <addresses>
          <address url="http://someurl" proxyServer="http://1.1.1.1" timeOutMS="600" maxTimeMS="100" />
        </addresses>
      </config>
      <serviceWindows>
      </serviceWindows>
    </collectorEntry>
    <collectorEntry uniqueID="2ae12433-bc0a-4a92-a1c5-5f194bf0bcca" name="Test" enabled="True" isFolder="False" collector="PerfCounter" dependOnParent="" collectOnParentWarning="False" repeatAlertInXMin="0" alertOnceInXMin="0" delayErrWarnAlertForXSec="0">
      <config>
        <performanceCounters>
          <performanceCounter computer="." category="Processor" counter="% Processor Time" instance="_Total" returnValueInverted="False" warningValue="0.10000002384186" errorValue="0.20000004768372" />
        </performanceCounters>
      </config>
      <serviceWindows>
      </serviceWindows>
    </collectorEntry>
  </collectorEntries>
  <notifierEntries>
    <notifierEntry name="Logging" notifier="LogFile" enabled="True" alertLevel="Debug" detailLevel="All">
      <config>
        <logFile path="C:\Temp\logs.log" createNewFileSizeKB="0" />
      </config>
      <collectors />
    </notifierEntry>
  </notifierEntries>
</monitorPack>

Coordinator
Oct 24, 2011 at 11:41 AM

First off - make sure the service runs under an account that has access to the right resources! e.g. Access to the file system. When using smtp you can specify a separate user account and password for authentication. For testing you can use your own user account or create a dedicated account on the machine that has access to the hdd (NTFS permissions and so on). Do not use accounts like Local System, Network account etc.

Oct 24, 2011 at 12:35 PM

Ah OK, I finally got the emails to come through. I haven't managed to get it to log to a file though but the emailing is probably more important at this stage.

I had the service running as Local Service. So I created a QuickMon user and let it run as that.

Thanks a lot.